Author Topic: Kawasaki versy 1000 missfire  (Read 502 times)

0 Members and 1 Guest are viewing this topic.

Offline Goldeneagle

  • Versys Newbie
  • *
  • Posts: 2
  • Bike: Kawasaki versy 1000
  • City / Town: Fleetwood
  • Country: gb
Kawasaki versy 1000 missfire
on: June 16, 2021, 08:27:29 PM
Hi don't know if anyone can help but I have a versy 1000 13 plate only 7k on the clock and when I'm opening the bike up it hits a flat spot like there's not enough fuel getting through I've had it plugged in and No error codes also had it on a dyno and still went flat any suggestions or has anyone experienced similar problems thx
Last Edit: June 16, 2021, 09:02:54 PM by Goldeneagle

Offline Huggy63

  • Versys Newbie
  • *
  • Posts: 8
  • Bike: Klz1000
  • City / Town: Pewsey
  • Country: gb
Re: Kawasaki versy 1000 missfire
Reply #1 on: June 16, 2021, 08:54:30 PM
Hi Goldeneagle, sounds like a similar problem I had with my bike a change to a few tanks of super unleaded fuel ( no ethenol) seemed to fix the problem, other sugestions where to have the ECU flashed, still looking into this. Have a look at thread fueling issues.

Offline TYKE

  • Versys Mega God
  • ******
  • Posts: 10917
  • Bike: BMW R 1250 GS TE
  • City / Town: Cumbria * U.K
  • Country: gb
Re: Kawasaki versy 1000 missfire
Reply #2 on: June 16, 2021, 08:55:16 PM
Might help those forum members who are technically minded if they knew what year of bike you have and what mileage

Maybe drop in to the new members section and tell us a bit more about yourself    :169: 
The world is full of good people, if you can't find one - be one

Make every second count, make every moment special.

Rog

Offline Goldeneagle

  • Versys Newbie
  • *
  • Posts: 2
  • Bike: Kawasaki versy 1000
  • City / Town: Fleetwood
  • Country: gb
Re: Kawasaki versy 1000 missfire
Reply #3 on: June 16, 2021, 09:05:23 PM
*Originally Posted by Huggy63 [+]
Hi Goldeneagle, sounds like a similar problem I had with my bike a change to a few tanks of super unleaded fuel ( no ethenol) seemed to fix the problem, other sugestions where to have the ECU flashed, still looking into this. Have a look at thread fueling issues.
thanks for the quick reply I'll try the fuel change